
 

 

 

  

How To Guide 

SAP Business One 9.0  

Document Version: 1.0 – 2014-01-15 

PUBLIC 

How to Work with Blanket Agreements 
All Countries 



 

2 

PUBLIC  

© 2014 SAP AG. All rights reserved. 

How to Work with Blanket Agreements 

Typographic Conventions 

 

Typographic Conventions 

Type Style Description 

Example Words or characters quoted from the screen. These include field names, screen titles, 

pushbuttons labels, menu names, menu paths, and menu options. 

Textual cross-references to other documents. 

Example Emphasized words or expressions. 

EXAMPLE Technical names of system objects. These include report names, program names, 

transaction codes, table names, and key concepts of a programming language when they 

are surrounded by body text, for example, SELECT and INCLUDE. 

Example Output on the screen. This includes file and directory names and their paths, messages, 

names of variables and parameters, source text, and names of installation, upgrade and 

database tools. 

Example Exact user entry. These are words or characters that you enter in the system exactly as they 

appear in the documentation. 

<Example> Variable user entry. Angle brackets indicate that you replace these words and characters 

with appropriate entries to make entries in the system. 

EXAMPLE  Keys on the keyboard, for example, F2  or ENTER . 
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Introduction 

Blanket agreements are long-term contracts between a purchasing organization and a vendor, or a sales 

organization and a customer, for the supply of items or provision of services over a period of time based on 

predefined terms and conditions. Blanket agreements can be used as a basis for expected revenue forecasts, 

quantity reservation, and for Material Requirements Planning (MRP). 

SAP Business One provides the following two methods for managing blanket agreements: 

 Items method - agreement to sell or purchase specific items within a predefined time frame. This method lets 

you define a planned item quantity and a price for the item that will be valid when the blanket agreement is 

linked to marketing documents. 

 Monetary method - agreement to sell or purchase goods at a predefined amount and within a predefined 

time frame. This method lets you define a planned amount and a discount to be applied on the price from the 

BP's pricelist when the blanket agreement is linked to marketing documents. 

Each of the two methods mentioned above lets you choose one of the following provided blanket agreement 

types: 

 General - blanket agreements are used to track fulfillment of terms to obtain a special bonus at year end, for 

example, for selling or purchasing a certain quantity of an item or for achieving a defined turnover. They are 

also used to determine a delivery schedule, for example, by defining the intervals at which a specific quantity 

of goods should be delivered. 

 Specific - blanket agreements are used to track fulfillment of terms to obtain a special discount for the 

individual sales or purchasing transaction. They are also used to determine a delivery schedule, for example, 

by defining the intervals at which a specific quantity of goods should be delivered. 

If a valid blanket agreement exists with a customer or vendor, SAP Business One automatically links sales and 

purchasing documents to the blanket agreement. This way the prices or the discount agreed upon with the 

business partners can be copied directly into the sales and purchasing documents. You can also choose to 

remove the link and create a sales or purchasing document that is not governed by a blanket agreement. 
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Managing Blanket Agreements 

You can add new blanket agreements according to your agreements with your suppliers/customers. You must 

approve any new blanket agreement before it can be used in SAP Business One. You can also update an existing 

blanket agreement, as long as its status is not Approved, Terminated, or Cancelled. 

Blanket Agreement Fields 

The Blanket Agreement window lets you define and manage blanket agreements. To access the window, from the 

SAP Business One Main Menu, choose Sales - A/R → Sales Blanket Agreement or Purchasing - A/P → Purchase 

Blanket Agreement. 

 

 

Header Area 

Use the header area to specify or view general information relevant to all items in the agreement: 

Field User Action/Description 

BP Code Specify the code of the business partner with whom you have made the agreement 

(mandatory field). 
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Field User Action/Description 

BP Name The default BP name is displayed. 

Contact Person The BP's default contact person is displayed. From the dropdown list, you can choose 

any other contact person of the current BP. 

Telephone No. The BP's default contact person’s telephone number, which is taken from the Tel 1 field 

on the Contact Person tab in the Business Partner Master Data window. If no value is set 

in this field, the BP's telephone number, defined on the General tab, is used. 

E-Mail The BP's default contact person’s e-mail address, which is taken from the  

E-Mail field on the Contact Person tab in the Business Partner Master Data window. If no 

value is set in this field, the BP's e-mail address, defined on the General tab, is used. 

Description Enter a descriptive text for the agreement, if required. 

No. Automatically assigned sequential number of the agreement according to the selected 

series in the next field. The default series is automatically selected, but you can choose 

other series. For more information about defining series, see Managing Series for 

Blanket Agreements below. 

Agreement Method The way that you choose to manage this agreement: 

 Items Method - The agreement is based on a commitment to sell/purchase specific 

items within a predefined time frame (default value). 

 Monetary Method - The agreement is based on a commitment to sell/purchase 

goods at a predefined amount and within a predefined time frame. 

Start Date Specify the date on which the agreement becomes effective (mandatory field). The 

default date is the date on which the agreement is created. 

End Date Specify the date until which the agreement is effective (mandatory field). The default 

date is blank. 

Termination Date Date on which the blanket agreement ceases to be effective, if the agreement is 

terminated before the actual end date. 

  Note 

 When you enter a date in this field, the agreement status changes to 

Terminated. 

Signing Date 

 
Specify the date on which the agreement was signed (mandatory field). The default date 

is the start date of the agreement. 

Note 

The signing date can be set to a date earlier than the start date but cannot be 

set to a date later than the end date. 

Note 

The signing date must be valid for the selected blanket agreement series in case 

the series is related to a specific period indicator. 
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General Tab 

Use the General tab to specify or view the general terms of the agreement. 

 

 

 

Specify the following information: 

Field User Action/Description 

Agreement Type The kind of agreement you have made with your business partner: 

 General 

Used if the terms of the agreement aim at achieving a certain number of items 

or turnover with the business partner and thus obtaining a special bonus after 

the agreement is fulfilled. 

 Specific 

Used if a special discount is to be given for each business transaction related to 

the agreement, or if a certain delivery plan has been agreed upon, for example, 

the sale or purchase of a certain quantity or value of items at regular intervals. 

Payment Terms Select payment terms for the blanket agreement. By default, the field is empty. 

 Note 

This field is available only when the setting Block Multiple Blanket 

Agreement for Same AP/AR Document is selected. For more information 

about this setting and about the Payment Terms field, see Adding Blanket 

Agreement to Document's Journal Entry below. 

Ignore Prices/Discount(*) 

Specified in Blanket 

Agreement 

(*Prices- for Items Method 

Discount- for Monetary 

Method) 

When the blanket agreement is of type General, the checkbox is selected and 

disabled. It means that when you relate the blanket agreement to sales or 

purchasing documents, the price list or special prices that may have been defined 

for the business partner take precedence in sales and purchasing documents over 

the price/discount you specify in the blanket agreement. 

When the blanket agreement is of type Specific, the checkbox is deselected and 

disabled. It means that when you relate the blanket agreement to sales or 

purchasing documents, the prices/discount specified in the blanket agreement 

take precedence in sales and purchasing documents over other prices you define. 
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Field User Action/Description 

Settlement Probability % Specify a percentage value to indicate how probable it is that the business partner 

will pay for the goods. 

Status Select the status of the blanket agreement. 

 Approved 

You can create sales or purchasing documents associated with the blanket 

agreement. 

 On Hold 

The blanket agreement is set to inactive, and you cannot create sales or 

purchasing documents associated with the blanket agreement. 

 Draft 

The blanket agreement is not approved, and you cannot create sales or 

purchasing documents associated with the blanket agreement. 

 Terminated 

The blanket agreement is concluded. Once you set a blanket agreement as 

terminated, regardless of the termination date you define, SAP Business One 

considers this blanket agreement as ended, and you can no longer create sales 

or purchasing documents associated with the blanket agreement. 

The default value in this field is Draft. 

 Note 

Status Draft can be changed to Approved. 

Status Approved can be changed to On Hold or Terminated. 

Status On Hold can be changed to Approved or Terminated. 

Price List Select a price list for the blanket agreement. By default, the price list assigned to 

the business partner on the Payment Terms tab in Business Partners → Business 

Partners Master Data is selected. 

 Note 

This field is available only when the agreement method is Monetary. 

When the agreement type is Specific, and the blanket agreement is associated to a 

document row, the price from the selected price list in this field is taken to the 

document's row. 

In addition, the discount defined in the blanket agreement is applied to the price 

from the selected price list. 

 Note 

When the agreement type is General, the price list is ignored. 

Owner Name of the user who is responsible for the blanket agreement. . 

Renewal Enables you to set a reminder for renewing a blanket agreement before it expires. 

Reminder 

 

The number of days, weeks, or months for the alert to appear prior to the 

termination of the blanket agreement. You can specify a value in this field only after 

you select the Renewal checkbox. 
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Field User Action/Description 

Remarks Enter comments about the general terms of the agreement, if required. 

Details Tab 

Use the Details tab to specify or view the items that can be purchased or sold within the terms of the blanket 

agreement, or in the case of a monetary agreement, the amount and the discount that are defined for the 

agreement. 

 

 

 

For an Items Method agreement, specify the following information: 

Field User Action/Description 

Item No. Number of the item that is covered by the blanket agreement (mandatory field). 

Item Description Item description, as maintained in the item master data. 

Item Group Item group, as maintained in the item master data. 

Planned Quantity Total quantity of items that are supposed to be sold or bought within the terms of 

the blanket agreement (mandatory field).  

The value in this field must be greater than zero. 

Unit Price Price of the item that you agreed upon with the business partner. 

Cumulative Quantity The number of those items that are included in sales or purchasing transactions 

associated with the blanket agreement. This value is filled in by the system. 

Cumulative Amount 

Cumulative Amount (LC) 

Cumulative Amount (FC) 

 

The monetary value of those items which are included in sales or purchasing 

transactions associated with the blanket agreement. This value is filled in by the 

system. 

When BP currency is foreign, the local currency amount is converted according to 

the rate in effect in the exchange rate table on the start date of the blanket 

agreement. 

Open Quantity 

 

The number of items associated with the blanket agreement that are not yet 

included in sales or purchasing transactions, that is, the planned quantity minus 

the cumulative quantity. This value is filled in by the system. 

Open Amount (LC)  

Open Amount (FC) 

The monetary value of the open quantity, that is, of the items associated with the 

blanket agreement that are not yet included in sales or purchasing transactions. 
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Field User Action/Description 

This value is filled in by the system. 

When BP currency is foreign, the local currency amount is converted by the rate in 

effect in the exchange rate table on the start date of the blanket agreement. 

Free Text Specify free text for the item, if required. By default, the text is copied to the row 

details of the current item.  

UoM Unit of Measurement – Type of unit by which the inventory is managed, as defined 

in the item master data. You can change this value at any time. 

Portion of Returns % Specify a percentage value for the probability that the goods will be returned by the 

business partner. 

End of Warranty Specify the date on which the goods warranty expires. 

 Note 

This field is not related to any warranties you may have defined in the 

Service module of SAP Business One. 

Item Row Status Indicates whether the item row is open and active, or closed. Default value is Open; 

after closing the row it is set to Closed. For more information about this 

functionality, see Closing Rows below. 

 

For a Monetary Method agreement, specify the following information: 

Field User Action/Description 

Planned Amount (LC) 

Planned Amount (FC) 

The amount that is supposed to be sold or bought within the terms of the blanket 

agreement (mandatory field). 

The value in this field must be greater than zero. 

When BP currency is foreign, the local currency amount is converted according to 

the rate in effect in the exchange rate table on the start date of the blanket 

agreement. If no start date is set, the exchange rate is taken from the system date. 

Line Discount The discount rate for the agreement amount that you agreed upon with the business 

partner. 

 Note 

When the agreement type is Specific, this discount is applied on the prices 

from the BP's price list as defined in the BP master data. This discount is 
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Field User Action/Description 

moved to the discount column when you generate a marketing document for 

the agreement's BP. 

Cumulative Amount (LC)   

Cumulative Amount (FC) 

 

The total amounts which are included in sales or purchasing transactions associated 

with the blanket agreement. This value is filled in by the system. 

When BP currency is foreign, the local currency amount is converted according to 

the rate in effect in the exchange rate table on the start date of the blanket 

agreement. 

Open Amount (LC)  

Open Amount (FC) 

The amount out of the planned amount that is not yet included in sales or purchasing 

transactions. This value is filled in by the system. 

When BP currency is foreign, the local currency amount is converted by the rate in 

effect in the exchange rate table on the start date of the blanket agreement. 

Free Text Specify free text for the row, if required. 

Portion of Returns % Specify a percentage value for the probability that the goods will be returned by the 

business partner. 

End of Warranty Specify the date on which the goods warranty expires. 

 Note 

This field is not related to any warranties you may have defined in the 

Service module of SAP Business One. 

 

Whether the blanket agreement type is Specific or General, you can specify details of a delivery plan for an item or 

for a specific amount, for example, the intervals at which an item should be delivered. On the Details tab, double-

click a specific row or right-click and choose Details. The Row Details - Blanket Agreement window appears. 

 

Specify the following information: 

Field User Action/Description 

Frequency Item/amount release period, for example, daily, weekly, monthly, or one-time. 

 Daily: The quantity/amount is divided by the number of days within the period you 

define for the item/amount line. 
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Field User Action/Description 

 Weekly: The quantity/amount is divided by the number of weeks within the period, 

starting with the From date and with the end of the last week falling closest to or 

on the To date. If the period is less than a week, the total quantity/amount is 

assigned to the From date. 

 Monthly, Quarterly, Semi-Annually, and Annually follow the same principle as 

Weekly. 

 One Time: This represents a single instance, so the whole quantity/amount relates 

to the From date only. 

From Start date of the release plan, that is, the date on which release against the blanket 

agreement starts. This date cannot be earlier than the start date of the blanket 

agreement. 

To End date of the release plan, that is, the date until which release against the blanket 

agreement takes place. This date cannot be later than the end date of the blanket 

agreement. 

Release Enter information related to a specific release against the blanket agreement, for 

example, release date and remarks. 

Quantity/Planned 

Amount (*) 

(*Quantity - for Items 

Method 

Planned Amount - for 

Monetary Method)  

Number of items/amount to be released during the release period. The total number 

of this column must be lower than or equal to the Planned Quantity/Planned Amount 

on the Blanket Agreement Details tab. 

Warehouse 

(Only for Items 

Method) 

Warehouse from which the goods should be released. 

Default value is the default item's warehouse. 

Free Text Specify free text, if required. 

Consume Forecast 

(Only for Items 

Method) 

To the item in blanket agreements to consume forecast, select the checkbox. 

When the checkbox in this column is selected, in the MRP run, the application 

subtracts the item's open quantities in blanket agreements (of type Specific) from the 

forecasted quantities. 

 Note 

To consume forecast using blanket agreements, you must also select the 

Consume Forecast checkbox in General Settings → Inventory tab. 

The default value is taken from the Consume Forecast setting in General Settings → 

Inventory tab. For purchase blanket agreements with vendors, it is always set to No. 

Activity To record an activity, such as a phone call or meeting, associated with the blanket 

agreement, click the yellow arrow and specify the required information. 

The BP Code, Name, and Contact Person from the agreement are copied to the activity 

and the activity type is Phone Call by default. 

 Note 
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Field User Action/Description 

You can also link the Blanket Agreement document in the Activity form itself 

on the Linked Document tab. 

 Note 

It is possible to add, update, and delete/close any item's line only when the blanket agreement status is 

Draft or On Hold. Under the status On Hold, it is possible to update only rows that have no linked 

documents. 

Closing Rows 

When a blanket agreement is defined as Items Method and its status is On Hold, it is possible to close certain rows, 

if required. This functionality can be used, for example, when a mistake was made in the item details and the 

agreement is already approved, or when the quantity of a specific item is not going to be fulfilled after documents 

were already linked to this item in the blanket agreement. This way, you can avoid having to cancel an entire 

agreement. 

To close a row, go to an On Hold blanket agreement → Items tab. Choose the relevant row, right-click the row 

number, select Close Row. Alternatively, from the menu bar, choose Data → Close Row. 

 Note 

o After closing a row, it is possible to add the same item to the same blanket agreement or add it to a 

different blanket agreement with the same period.  

o New documents cannot be linked to closed rows (automatically or manually), whereas existing linked 

documents remain on the Documents tab.  

o Open Quantity and Open Amount values of closed rows are set to zero, whereas Planned Quantity, 

Cumulative Quantity, and Cumulative Amount values remain the same as they were before closing the 

row and will be considered when calculating totals. 

o Line details of closed rows are not considered when running Cash Flow and MRP. For more 

information about those related modules see Cash Flow and MRP below. 

Documents Tab 

Use the Documents tab to view the document lines associated with the blanket agreement. 

 

View the following information about existing documents associated with the blanket agreement: 

Field User Action/Description 

Document Type Type of the document that was created and associated with the blanket 

agreement, for example, a sales order or A/P invoice. 
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Field User Action/Description 

Document No. Number of the document that was created and associated with the blanket 

agreement. 

Posting Date Posting date of the document that was created and associated with the blanket 

agreement. 

Item No. Item code from the document line that is associated with the blanket agreement. 

It remains empty in the case of a Service document type. 

Item Description Item description from the document line that is associated with the blanket 

agreement. 

Row No. Number of the row in the document that is associated with the blanket 

agreement. 

Unit Price Price of the item used in the sales or purchasing document. 

Quantity Quantity of the item used in the sales or purchasing document. 

Discount Discount from the document line that is associated with the blanket agreement. 

UoM Unit of measurement of the item used in the sales or purchasing document. 

Document Row Status The status of the document row that is associated with the blanket agreement. 

 Note 

By default, documents are displayed according to the document date, with the oldest one displayed at the 

bottom and then in ascending sequence according to document number. You can change the display 

order by using the sort function or the filter function located in the upper icons bar. 

Attachments Tab 

Use the Attachments tab to manage files used in the blanket agreement. 

 

Field User Action/Description 

Path Displays the path of the attached file. 

File Name Displays the name of the attached file. 

File Extension Displays the extension of the attached file. 

File Size Displays the size of the attached file. 

Attachment Date Displays the date on which the file was attached. 
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Field User Action/Description 

Attached By Displays the user who attached the file. 

To attach a file to the blanket agreement, choose Browse. 

To open an attached file, select the file and choose Display. 

To remove an attached file from the attachments table, select the file and choose Delete. 

Recurring Transactions Tab 

Use the Recurring Transactions tab to link recurring transactions templates to the blanket agreement and to view 

linked recurring transactions that were executed or are waiting to be executed. 

 

Specify the following information: 

Field User Action/Description 

Template To link a recurring transactions template, enter the template code or choose from 

list. 

 Note 

Only templates defined for the same BP as the one in the blanket 

agreement appear in the list. 

Type Displays the type of the selected recurring transactions template. 

 Note 

 You can link more than one recurring transactions template to the same blanket agreement. 

 

To view and track the transactions of any template, select the checkbox to the left of the specific template code. 

Then the transactions are displayed in the Recurring Transaction table with the following details: 

Field User Action/Description 

Template Displays the recurring transactions template code. 

Instance Displays the instance number of the recurring transaction. 

Status Displays the instance status, whether it has already been executed or not. 

Date Displays the date for which the recurring transaction is set. 
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Field User Action/Description 

Doc, Total Displays the total of the document created in the recurring transaction. 

 Note 

 Executed recurring transactions cannot be removed from the blanket agreement. 

Managing Series for Blanket Agreements 

You can define different series for customers' blanket agreements separately from vendors' blanket agreements, 

in the same way you define series for all other documents. 

Procedure 

1. From the SAP Business One Main Menu choose Administration → System Initialization → Document 

Numbering. 

The Document Numbering - Setup window appears. 

 

2. Double-click the Blanket Agreement - Customer row or the Blanket Agreement - Vendor row for which you 

want to add new series or update existing ones. 

The Series - Blanket Agreements - Customer/Vendor - Setup window appears. 
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3. You can set the different attributes for the primary series. To add new series, right-click the row number and 

choose Add Row. 

 Note 

The rules for adding and updating series for blanket agreements are the same rules as for all other 

marketing document series. For more information, see the online help for SAP Business One. 

Adding New Blanket Agreements 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement or Purchasing A/P → 

Purchase Blanket Agreement. The Sales/Purchase Blanket Agreement window appears in Find mode.  

Switch to Add mode. 
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2. In the header area, specify the following: 

o Business partner code or name 

o Agreement method: Items or Monetary 

o Start date of the agreement 

o End date of the agreement 

3. Optional: In the Description field, enter a short description of the blanket agreement. 

4. On the General tab, select the agreement type General or Specific and do the following: 

1. Specify the status of the agreement. 

 Note 

You can create sales and purchasing documents associated with a blanket agreement only if the blanket 

agreement has the status Approved. 

 Note 

To be able to set the blanket agreement status you must have the appropriate authorizations. For more 

information about the authorizations required, see the document How to Define Authorizations, which 

you can download from the documentation area of SAP Business One Customer Portal at 

http://service.sap.com/smb/sbocustomer/documentation. 

2. To receive a reminder before the blanket agreement expires, select the Renewal checkbox. 

For more information about the individual fields on this tab, see Blanket Agreement Fields, above. 

5. On the Details tab, specify the items, prices, and quantities governed by the agreement, or in the case of a 

monetary agreement, specify the planned amount and the discount. 

For more information, see Blanket Agreement Fields, above. 

 Note 

For the same period of time, for each business partner and a certain item, only one approved blanket 

agreement is allowed to exist. As well, an approved Monetary agreement cannot exist if an approved 

http://service.sap.com/smb/sbocustomer/documentation
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Items agreement already exists for the same period of time and the same business partner, and vice 

versa. 

6. To enter detailed information, such as the intervals at which items should be released against the blanket 

agreement, double-click the item line. 

1. In the Row Details - Blanket Agreement window that appears, enter the following mandatory information: 

o Frequency 

o From and To dates 

o Quantity/Planned Amount 

o Consume Forecast 

2. Choose Update and OK. 

For more information, see Blanket Agreement Fields, above. 

7. To attach the signed agreement document to the blanket agreement in SAP Business One, on the 

Attachments tab, choose the Browse button to navigate to and append the file. 

8. To save the blanket agreement, choose Add. 

Approving Blanket Agreements 

To be able to buy or sell items according to a blanket agreement, the agreement first must be approved. 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement or Purchasing A/P → 

Purchase Blanket Agreement. 

2. Open the relevant blanket agreement in Find mode. 

3. Set the status of the blanket agreement to Approved and choose Update. 

4. To exit the blanket agreement, choose OK or Cancel. 

Copying Blanket Agreements to Marketing Documents 

You can copy blanket agreements to and from marketing documents. 

 Note 

The copy action lets you save time reentering the items in the marketing document. It does not have any 

other impact, neither on the blanket agreement nor on the marketing document. 

 

Copy To Procedure  

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement or Purchasing A/P → 

Purchase Blanket Agreement. 

2. Open the relevant blanket agreement in Find mode. 

3. Choose the Copy To button, and from the dropdown list, select the relevant document. 
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 Note 

To copy the blanket agreement to marketing documents, it must be of Items Method and its status must 

be Approved. 

The blanket agreement date range must be valid for the system date since, by default, this is the date set 

for the marketing document. 

Results 

The business partner details and the details of the items are copied from the blanket agreement to the selected 

target document. 

The payment terms selected in the blanket agreement are copied to the marketing document, replacing the 

default payment terms of the business partner. 

Copy From Procedure 

1. From the SAP Business One Main Menu, choose any sales or purchase marketing document. 

2. Enter a business partner. 

3. Choose the Copy From button and from the dropdown list, select Blanket Agreement. 

 Note 

In an A/P invoice document, first enter the posting date, then select Copy From and choose a blanket 

agreement. 

4. In the List of Blanket Agreements window, select the relevant blanket agreement and choose the Choose 

button. 

 Note 

The List of Blanket Agreements window displays all approved blanket agreements for the specific 

business partner that are valid for the document's posting date. 

 

5. In the Draw Document Wizard window, you can choose whether to draw all data to the marketing document or 

to customize the data first. 

Results 

All rows of open items from the blanket agreement are copied to the marketing document. 

Changing Blanket Agreements 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement or Purchasing A/P → 

Purchase Blanket Agreement. 

2. Open the relevant blanket agreement in Find mode. 

3. Modify the necessary fields and choose Update. 

4. To exit the blanket agreement, choose OK or Cancel. 
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 Note 

Blanket agreements with the status Terminated or those that were canceled cannot be updated at all.  

Blanket agreements with the status Approved or On Hold can be updated only in certain fields. 

For a detailed list of those fields, see Updating Blanket Agreements, below. 

Duplicating Blanket Agreements 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement or Purchasing A/P → 

Purchase Blanket Agreement. 

2. Open the relevant blanket agreement in Find mode. 

3. Right-click in the agreement and from the dropdown list, select Duplicate. Alternatively, from the menu bar, 

choose Data → Duplicate. 

The agreement status changes to Draft.  

4. Change details as required. 

5. To add the new blanket agreement, choose Add. 

Terminating Blanket Agreements 

It is possible to terminate a blanket agreement before it has reached its end date. 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement - Customer or 

Purchasing A/P → Purchase Blanket Agreement. 

2. Open the relevant blanket agreement in Find mode. 

3. In the Termination Date field of the header area, specify the date on which the agreement ceases to be 

effective and choose Update. 

The agreement status changes to Terminated and no additional sales or purchase documents can be 

associated with this agreement. 

4. To save the changes, choose Update. 

5. To exit the blanket agreement, choose OK or Cancel. 

Canceling Blanket Agreements 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Sales Blanket Agreement - Customer or 

Purchasing A/P → Purchase Blanket Agreement. 
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2. Open the relevant blanket agreement in Find mode. 

3. Right-click in the agreement and from the dropdown list, select Cancel. Alternatively, from the menu bar, 

choose Data → Cancel. 

The agreement status changes to Cancelled. No additional actions can be performed in this blanket 

agreement nor can any document be associated with this agreement. 

Other Functionalities 

User Defined Fields  

To add your own fields to the blanket agreement, from the menu bar, choose Tools → Customization Tools → 

User-Defined-Fields – Management, and under Master Data → Blanket Agreement, add the fields. 

For information about how to define user fields, see the document How to Create User-Defined Fields and Tables, 

which you can download from the documentation area of SAP Business One Customer Portal at 

http://service.sap.com/smb/sbocustomer/documentation. 

Printing Blanket Agreements 

To print a blanket agreement, use the default Crystal Reports template. To do so, open the relevant blanket 

agreement and click the Print icon, or from the menu bar, choose File → Print.  

http://service.sap.com/smb/sbocustomer/documentation
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Adding Blanket Agreements to a Document's 
Journal Entry 

When creating a marketing document, you might want to associate the linked blanket agreement also to the 

document's journal entry, in order to, for example, enable analysis of financial reports by blanket agreement. 

To enable this functionality, there is an option which lets you define that only one blanket agreement is to be 

linked to a certain document. The number of the blanket agreement then is added to the document's journal 

entry. 

You can activate this setting for only A/P documents or only A/R documents or both. 

Prerequisites 

From the SAP Business One Main Menu, choose Administration → System Initialization → Document Settings → 

General tab. 

 To apply this functionality to A/P documents, select the Block Multiple Blanket Agreements for Same A/P 

Document checkbox. 

 To apply this functionality to A/R documents, select the Block Multiple Blanket Agreements for Same A/R 

Document checkbox. 

 Note 

By default, the two checkboxes are not selected, meaning you can link different blanket agreements to 

the same document and the blanket agreement number is not displayed in the document's journal entry. 

Procedure 

1. Start to create a new marketing document by opening the relevant document in Add mode. 

2. Specify the following information: 

o Business partner code 

o Posting date 

3. SAP Business One automatically associates a valid blanket agreement according to different rules based on 

the defined settings, as detailed in Rules for Linking Blanket Agreements below. 

You can manually change the blanket agreement to another valid blanket agreement. 

For example, when the settings do not allow multiple blanket agreements in the same period and block 

multiple blanket agreements in the same documents, then a valid blanket agreement that matches the 

document's posting date is taken automatically to the Blan. Agreement field on the Accounting tab.  

 Note 

By default, no blanket agreement is associated automatically to a Purchase Quotation. You can select a 

valid blanket agreement manually. 

4. Choose items. 



 

How to Work with Blanket Agreements 

Adding Blanket Agreements to a Document's Journal Entry 

 PUBLIC  

© 2014 SAP AG. All rights reserved.  25 

 

 Note 

Once a blanket agreement is associated to the document's header on the Accounting tab, you can choose 

only items that are valid in the associated blanket agreement. 

 Note 

When you select the setting Block Multiple Blanket Agreements for Same Document, the Blanket Agreement 

column in the document's row is disabled and you cannot choose a blanket agreement in the row level or change 

the value in this column. 

  

5. To save the document, choose Add and OK. 

Results 

The number of the valid blanket agreement is displayed in the Blan. Agreement field, which is located on the 

Accounting tab of the document. 

 The document's blanket agreement number is displayed in the Blan. Agreement field, which is located in the 

header of the document's journal entry. 

 Note 

The Blan. Agreement field in the document header and in the journal entry header is displayed only when 

Block Multiple Blanket Agreement for Same Document is selected on the General tab in Administration → 

System Initialization → Document Settings 

Other Functionalities 

 Payment Terms - When you select the Block Multiple Blanket Agreements for Same Document setting, you 

can set payment terms in the blanket agreement, and then the following rules are applied: 

o When a blanket agreement with payment terms is associated automatically to a document header or is 

chosen manually in a document, the payment terms from the blanket agreement, instead of the existing 

document's payment terms, are set in the document. 

o When you clear the blanket agreement from the document header, the payment terms are refreshed from 

the business partner master data. 

o When you replace the document's current blanket agreement with another one, payment terms are 

refreshed with the payment terms in the new selected blanket agreement. 

 Note 

When you deselect the Block Multiple Blanket Agreements for Same Document setting, the payment 

terms selected in the blanket agreements are removed. A relevant message is displayed before the 

payment terms are removed. 

 

 Copy From/ Copy To - When using the Copy From functionality, you can select only documents with the 

same associated blanket agreement in the header. 

 Note 

You can display the blanket agreement number of the document in the list of documents window when 

copying the document using the Copy From button. 
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 Document Generation Wizard -  

o In the Document Generation Wizard you can select documents by blanket agreement criteria. Then the 

base documents are restricted to the selected blanket agreement. 

o Documents with different blanket agreements in their headers are not consolidated, no matter which 

consolidation options are selected in the wizard. 

 Blanket Agreement in Reports Selection Criteria - You can generate some accounting reports and financial 

reports by blanket agreement. In addition, you can display the blanket agreement number in the results of the 

General Ledger report and of the Document Journal report.  
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Allowing Multiple Blanket Agreements for the 
Same BP and the Same Period  

You can decide to allow multiple blanket agreements for the same business partner, for the same period, and even 

for the same item, as a result of which you would get more flexibility when pricing goods and services. 

For example, you can create different blanket agreements for the same business partner, same period, and same 

item, where the price is set differently according to the payment terms defined in the blanket agreement. 

 Note 

The Payment Terms field in the Blanket Agreement window is available only when the setting Block 

Multiple Blanket Agreement in Same Document is selected. For more information about this setting and 

about the Payment Terms field, see Adding Blanket Agreement to Document's Journal Entry above. 

 Example 

Ability to define different prices according to the blanket agreement's payment terms: 

Blanket agreements No. 1 and No.2 are created for the same business partner, for the same period, and 

for the same item. 

In blanket agreement No. 1, payment terms A are selected and in blanket agreement No. 2 payment terms 

B are selected. 

Blanket agreement No. 1 - When the delivered goods are to be paid for after 1 month, according to the 

blanket agreement's payment terms (A), the discount is set to 5%. 

Blanket agreement No. 2 - When the delivered goods are to be paid for after 2 months, according to the 

blanket agreement's payment terms (B), the discount is set to 4%. 

 

After you set to allow multiple blanket agreements, you can define a default blanket agreement for each business 

partner in Business Partner Master Data → Payment Terms tab or in the blanket agreement itself. 

Prerequisites 

You have selected the Allow Multiple Blanket Agreements for Same Period checkbox in Administration → System 

Initialization → General Settings → BP tab. By default this checkbox is not selected. 

 Note 

You can deselect this checkbox, but only when there are no multiple approved blanket agreements for 

any business partner. 

Procedure 

1. Add at least 2 blanket agreements for the same business partner and for the same period and item (or any 

other combination of those parameters). 

2. Approve those blanket agreements. 

3. Set one of the defined blanket agreements as the default. 



 

28 

PUBLIC  

© 2014 SAP AG. All rights reserved. 

How to Work with Blanket Agreements 

Allowing Multiple Blanket Agreements for the Same BP and the Same Period 

 

 Note 

Only an approved blanket agreement can be defined as Default. 

 

 Note 

When you select the Set as Default field in any blanket agreement, the Dflt Blanket Agreement field on 

the Payment Terms tab in the Business Partner Master Data window is updated automatically with the 

number of the blanket agreement (also when you update the default blanket agreement number in the 

Business Partner Master Data the Set as Default field in the relevant blanket agreement is selected 

automatically). 

 

 Note 

Both the Set as Default field in the Blanket Agreement window, and the Dflt Blanket Agreement field in the 

Business Partner Master Data window are displayed only when the setting Allow Multiple Blanket 

Agreements for Same Period is selected. 

 

4. Go to any marketing document and choose the business partner from the defined blanket agreements. 

Results 

For any added new row in the document, the default blanket agreement is taken automatically according to the 

following rules: 

 When the default blanket agreement is of Monetary method, it is taken to the document's row if the blanket 

agreement dates are valid for the document's posting date. 

 When the default blanket agreement is of Items method, it is taken to the document's row if it is valid for the 

document's posting date and if the item matches the item from the blanket agreement and the row status is 

not closed. 

 Note 

The default blanket agreement can be changed manually to another valid blanket agreement. 
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Purchasing Goods Related to a Blanket 
Agreement 

You negotiated a blanket agreement with your vendor governing the purchase of a certain number of goods at a 

certain price or of a certain total amount with a certain discount, over a certain period of time. To record 

purchasing transactions in relation to the blanket agreement, you create purchasing documents such as purchase 

orders or invoices that are linked to the blanket agreement. 

In addition, you can set up recurring transactions to support the recurring purchasing transactions governed by 

the blanket agreement. For more information, see Recurring Transactions, below. 

Prerequisites 

A blanket agreement exists for the business partner and the specific item (in the case of an Item Method 

agreement), and the posting date of the purchasing transaction falls into the validity period of the agreement. 

Procedure 

1. Start to create a new purchasing document, for example, a purchase order or goods receipt PO, by opening a 

purchasing document in Add mode. 

2. Specify at least the following information: 

o Vendor code 

o Posting and delivery date 

o Item code (or amount, in the case of a Service type document) 

o Quantity (only in the case of an Item type document) 

SAP Business One checks whether a blanket agreement exists for this vendor, one that is valid on the 

specified posting date, and in the case of an items agreement, also covers the desired items. If there is such 

an agreement, the application enters the blanket agreement number into the Blanket Agreement column for 

each item/row. If the blanket agreement type is Specific, it also inserts the unit prices agreed upon in the 

blanket agreement. If the blanket agreement type is General, the prices in the blanket agreement are ignored 

and price is set by the prices hierarchy.  

 Note 

If the item quantity you have entered is larger than the open quantity of the blanket agreement, or if the 

unit price you have entered is different from the price in the blanket agreement, a relevant system 

message appears in the status bar. You can decide whether to proceed with the data you have entered or 

to change it according to the blanket agreement before adding the document. 

 Note 

When a valid monetary agreement exists and the price in the price list is zero, or when the document type 

is Service, the blanket agreement is linked to the document line, but the discount from the blanket 

agreement is not drawn into the line. 

3. If required, specify any additional data. 
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 Note 

When you perform an action that triggers price updating, such as changing payment terms in the 

document, the price update will be done only for lines which have no linked blanket agreement. The 

reason for this behavior is that the prices defined in the blanket agreement have the highest hierarchy of 

all prices. 

4. To save the document, choose Add and OK. 

  Note 

When copying documents (Copy From, Copy To), the linked blanket agreement from the base document 

is copied to the target document by default, even when the target document posting date is out of the 

date range of the linked blanket agreement. Before adding the target document, you can decide whether 

to: 

o Leave this blanket agreement for the target document 

o Manually choose a blanket agreement that complies with the target document posting date 

o Remove the linked blanket agreement completely 

If you choose a different blanket agreement for the target document, the document data will not be 

reflected in the blanket agreement of the base document. 

 Note 

When copying (Copy From) more than one document with different header discounts into a target 

document, the header discount is applied on the line discount. When a monetary agreement is linked to 

the base document, the line discount in the target document includes the blanket agreement discount 

and the header discount from the base document. 

Result 

SAP Business One creates a purchasing document associated with a blanket agreement. If the document involves 

inventory movement, the purchasing document has the following impact on the blanket agreement: 

 Increases the cumulative quantity and cumulative amount 

 Decreases the open quantity and open amount 

 Note 

In the event that you change the price in a target document, and the base document has already updated 

the cumulative amount in the linked blanket agreement, the resulting delta in the price is also updated in 

the cumulative amount when adding the target document. 

 Example 

The following blanket agreement was created for vendor V10000: 
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Then the following goods receipt PO was created for vendor V10000: 

 

o The price 30$ was taken from the valid blanket agreement and displayed in blue. 

o The blanket agreement number 1 with link arrow was displayed automatically. 

The same blanket agreement for vendor V10000 was updated accordingly: 
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o The cumulative quantity was increased to 5. 

o The cumulative amount was increased to 150$. 

o The open quantity was reduced to 95. 

o The open amount was reduced to 2,850$. 
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Selling Goods Related to a Blanket Agreement 

You negotiated a blanket agreement with your customer governing the sale of a certain number of goods at a 

certain price, or of a certain total amount with a certain discount, over a certain period of time. To record sales 

transactions in relation to the blanket agreement, you create sales documents such as deliveries or invoices that 

are linked to the blanket agreement. 

In addition, you can set up recurring transactions to support the recurring sales transactions governed by the 

blanket agreement. For more information about recurring transactions, see Recurring Transactions, below. 

Prerequisites 

A blanket agreement exists for the business partner, and the posting date of the sales transaction falls into the 

validity period of the agreement. 

Procedure  

1. Start to create a new sales document, for example, a sale order or delivery, by opening a sales document in 

Add mode. 

2. Specify at least the following information: 

o Customer code 

o Posting and delivery date 

o Item code (or amount, in the case of a Service type document) 

o Quantity (only in the case of an Item type document) 

SAP Business One checks whether a blanket agreement exists for this customer, one that is valid at the 

specified posting date and covers the desired items. If there is such an agreement, the application enters the 

blanket agreement number into the Blanket Agreement column for each item. If the blanket agreement type is 

Specific, it also inserts the unit prices agreed upon in the blanket agreement. If the blanket agreement type is 

General, the prices in the blanket agreement are ignored and price is set by the prices hierarchy. 

 Note 

If the item quantity you have entered is larger than the open quantity of the blanket agreement, or if the 

unit price you have entered is different from the price in the blanket agreement, a relevant system 

message appears in the status bar. You can decide whether to proceed with the data you have entered, or 

to change it according to the blanket agreement, before adding the document. 

3. If required, specify any additional data. 

 Note 

When you perform an action that triggers price updating, such as changing payment terms in the 

document, the price update will be done only for lines which have no linked blanket agreement. The 

reason for this behavior is that the prices defined in the blanket agreement have the highest hierarchy of 

all prices. 

4. To save the document, choose Add and OK. 
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 Note 

For a sales bill of materials, the blanket agreement can be linked only to a parent item. The price from the 

blanket agreement is inserted into the parent item line when the blanket agreement is of type Specific and 

the Price and Total for Parent Item Only checkbox in document settings is selected. 

 Note 

When copying documents (Copy From, Copy To), the linked blanket agreement from the base document 

will be copied to the target document by default, even when the target document posting date is out of 

the date range of the linked blanket agreement. Before adding the target document, you can decide 

whether to: 

o Leave this blanket agreement for the target document 

o Manually choose a blanket agreement that complies with the target document posting date 

o Remove the linked blanket agreement completely 

Note that if you choose a different blanket agreement for the target document, the document data will not 

be reflected in the blanket agreement of the base document. 

Result 

SAP Business One creates a sales document associated with a blanket agreement. If the document involves 

inventory movement, the sales document has the following impact on the blanket agreement: 

 Increases the cumulative quantity and cumulative amount 

 Decreases the open quantity and open amount 

 Note 

In the event that you change the price in a target document, and the base document has already updated 

the cumulative amount in the linked blanket agreement, the resulting delta in the price is also updated in 

the cumulative amount, when adding the target document. 

 Example 

The following blanket agreement was created for customer C20000: 
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Then the following A/R invoice was created for customer C20000: 

 

o The price 40$ was taken from the valid blanket agreement and displayed in blue. 

o The blanket agreement number 1 with link arrow was displayed automatically. 

The same blanket agreement for customer C20000 was updated accordingly: 
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o The cumulative quantity was increased to 8. 

o The cumulative amount was increased to 320$. 

o The open quantity was reduced to 62. 

o The open amount was reduced to 2,480$.  
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Related Modules 

Recurring Transactions  

Certain business transactions recur on a regular basis. For example, every month a company orders a stack of 

copying paper from their vendor. You can define templates for such recurring transactions using regular sales and 

purchasing document drafts. The templates contain the required business partner, item, accounting, and 

shipping information as well as any associated blanket agreement. 

In order to have a blanket agreement associated in the recurring transaction template, the draft document's 

posting date must be within the date range of the blanket agreement. 

Procedure 

From the SAP Business One Main Menu, choose Sales - A/R / Purchasing - A/P → Recurring Transactions 

Templates and define your template by adding a draft document. 

Result 

The blanket agreement is automatically associated to the recurring posting as long as the next execution is not 

beyond the blanket agreement's end date. 

When the execution date of the recurring posting is beyond the blanket agreement's end date, the recurrent 

posting fails and is not added. 

 Example 

The date range of blanket agreement No. 2 is from January 1, 2014 until March 31, 2014. 

c4 

A recurring transaction of Invoice was defined for the related customer and item of blanket agreement No. 

2, for the first of each month.  
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Once the draft invoice's posting date is in the date range of the blanket agreement, blanket agreement 

No.2 is automatically associated to the recurring transaction template. 

 

On the first of each month, an invoice can be added automatically via the recurring transaction. 

On April 1, 2014, if you try to add the invoice via a recurring transaction, a message notifies you that the 

associated blanket agreement is not valid and the recurring invoice cannot be added.   

For more information about recurring transactions, see the Online Help for SAP Business One. 

Cash Flow 

Approved blanket agreements for which item details (shipment information) were set, could be considered in the 

cash flow as part of the financial forecast. 

Procedure 

1. From the SAP Business One Main Menu, choose Financials → Financial Reports → Financial → Cash Flow.  

The Cash Flow - Selection Criteria window appears: 
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2. Select the Add Blanket Agreements checkbox and all other relevant data and choose OK. 

Result 

In the cash flow window, the approved blanket agreements with customers that contain row details are part of the 

Customer Liabilities, while the approved blanket agreements with vendors that contain row details are part of the 

Debts to Vendors. 

The forecast value is calculated according to the information in the Row Details - Blanket Agreement form, 

including the quantity/planned amount, unit price, frequency, from date and to date. 

The amount of the invoice line items that are linked to agreements is deducted from the agreement value in the 

cash flow, and the amount of the credit memo line items that are linked to agreements, is added to the agreement 

value in the cash flow. 

 Example 

The following blanket agreement was created for customer C03, for a quantity of 300 and at a 100 EUR 

unit price, including the information in the Row Details - Blanket Agreement form, a quantity of 100 per 

month: 
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The monthly calculated forecast value is 100EUR*100=10,000EUR and the blanket agreement is 

displayed in the cash flow as follows: 

 

Then an A/R invoice with the amount 3,000EUR was added, linked to the above blanket agreement: 
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The calculated forecast value for the relevant month is 100EUR*100–3000EUR=7000EUR and the 

blanket agreement is displayed in the cash flow as follows: 

 

MRP Module 

Approved blanket agreements for which item details (shipment information) were set, could be considered as 

data sources during MRP runs. 

MRP → MRP Wizard  



 

42 

PUBLIC  

© 2014 SAP AG. All rights reserved. 

How to Work with Blanket Agreements 

Related Modules 

 

 

 

For more information, see the document How To Configure and Use MRP in Release 8.8, which you can download 

from the documentation area of SAP Business One Customer Portal at 

http://service.sap.com/smb/sbocustomer/documentation. 

http://service.sap.com/smb/sbocustomer/documentation
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Displaying Available Blanket Agreements and 
Fulfillment Status 

To see at a glance all blanket agreements (Items or Monetary) that may exist with particular business partners or 

for certain date ranges, you can generate a Blanket Agreement Fulfillment Report. 

Procedure 

1. From the SAP Business One Main Menu, choose Reports → Sales and Purchasing → Blanket Agreements 

Fulfillment Report. Alternatively, open it from the Sales - A/R module or from the Purchase - A/P module. 

2. In the Blanket Agreements List – Selection Criteria window, specify the selection criteria for the report: 

 

3. Choose OK. 

Result 

The blanket agreements fulfillment report displays the following information: 

Field User Action/ Description 

Agreement No. Automatically assigned sequential number of the agreement. 

BP Code Code of the business partner with whom you have made the agreement. 

BP Name Name of the business partner with whom you have made the agreement. 

Start Date Date on which the agreement becomes effective. 

End Date Date until which the agreement is effective. 

Termination Date Date on which the blanket agreement ceases to be effective, if the agreement is 

terminated before the actual end date. When you enter a date, the agreement 

status changes to Terminated. 

Fulfilled Status Shows whether the terms of the agreement have been fulfilled for a particular item, 

that is, whether the number of items or monetary amount agreed upon has been 

reached. 

Type The kind of agreement (General or Specific) you have made with your business 
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Field User Action/ Description 

partner. 

Owner Name of the user who is responsible for the blanket agreement. 

Discount 

(only for Monetary 

Method) 

The line discount that is set in the blanket agreement. 

Item No. 

(only for Items Method) 

Number of the item that is covered by the blanket agreement. 

Item Description 

(only for Items Method) 

Item description as maintained in the item master data. 

Unit Price/Planned 

Amount 

Price of the item that you agreed upon with the business partner. 

Planned Quantity 

(only for Items Method) 

Total quantity of items that are supposed to be sold or bought within the realm of 

the blanket agreement. 

Cumulative Quantity 

(only for Items Method) 

The number of those items that are included in sales or purchasing transactions 

associated with the blanket agreement. This value is filled in by the system. 

Open Quantity 

(only for Items Method) 

The number of items that are not yet included in sales or purchasing transactions 

associated with the blanket agreement. That is, the planned quantity minus the 

cumulative quantity. This value is filled in by the system. 

 Note 

For closed rows, Open Quantity displays zero. For more information about 

the closing rows functionality, see Closing Rows, above. 

Cumulative Amount The monetary value of those items that are included in sales or purchasing 

transactions associated with the blanket agreement. This value is filled in by the 

system. 

Open Amount The monetary value of the open quantity, that is, of the items associated with the 

blanket agreement but not yet included in sales or purchasing transactions. This 

value is filled in by the system. 

 Note 

For closed rows, Open Amount displays zero. For more information about 

the closing rows functionality, see Closing Rows, above. 

Row Status 

(only for Items Method) 

Indicates whether the item row is open and active, or closed. For more information 

about the closing rows functionality, see Closing Rows, above. 

 Note 

Another way of seeing a list of blanket agreements for a specific business partner is to use the drag & 

relate functionality. For more information about the drag & relate functionality, see the Online Help for 

SAP Business One. 
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Localization Features 

Year Transfer - Israel and The Netherlands 

Administration → Utilities → Year Transfer 

In the third step of the Year Transfer process, you can transfer blanket agreements defined in the source 

company to the target company, as with all other documents that can be transferred. 

In step 3, select the Doc. Transfer checkbox and choose the Documents button. The Year Transfer window 

appears with a list of all the documents that can be transferred: 

 

 Note 

If you wish to transfer blanket agreements you must do it before creating any blanket agreements in the 

target company. Otherwise, you might create a situation whereby a new blanket agreement in the target 

company will get the same agreement number as an existing blanket agreement in the source company. 

In such a case, the blanket agreement from the source company is not transferred to the target company. 

 Note 

Transferred documents which were linked to a blanket agreement in the source company will no longer be 

linked to the blanket agreement in the target company. However, you can track the fulfillment status by 

the accumulated quantity and accumulated amounts in the transferred blanket agreement itself. 

For more information about the Year Transfer process, see the document How to Perform a Year Transfer, which 

you can download from the documentation area of SAP Business One Customer Portal at 

http://service.sap.com/smb/sbocustomer/documentation. 

http://service.sap.com/smb/sbocustomer/documentation
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Appendix 1 - Updating Blanket Agreements 

When updating an existing blanket agreement, different fields can be updated according to the blanket agreement 

status, as detailed in the below table: 

 Draft Approved On Hold Terminated/Cancelled 

BP Code X X X X 

BP Name X X X X 

End Date V X V X 

Agreement Method V X X X 

Adding rows V X V X 

Updating rows V X V 

Only those with no 

linked documents 

X 

Closing rows V  

Deleting rows 

X V X 

Updating Blanket 

Agreement Details 

V V V X 

Termination date V V V X 

Signing Date V X V X 

Contact person V V V X 

Description V V V X 

Set as Default X V X X 

Payment Terms V X V X 

Settlement Probability V V V X 

Status V V V X 

Price List V X V X 

Renewal V V V X 

Remarks V V V X 

Free text (Item tab) V V V X 

Attach document V V V X 

Linking recurring 

transactions template 

V V V X 
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Appendix 2 - Rules for Linking Blanket 
Agreements 

When creating or changing marketing documents, the rules for linking blanket agreements to the document differ 

according to the different settings made, as detailed below. 

A. When Block multiple BA on same document is not selected: 

 The blanket agreement in the document header is irrelevant. 

 In target documents, based rows inherit the BA from the base document with no validations (date/status). 

 When changing the posting date in target documents, BA is not refreshed in based rows, 

 When adding documents, BA in rows must be valid, except in based rows. 

Additional rules: 

Allow 

multiple BA 

on same 

period 

Default 

BA is 

set 

Adding new /Changing rows in  non-

base document or in target 

document 

Changing posting date in non-base 

documents or in non-based rows in 

target document 

No N/A Valid BA by posting date is selected 

automatically in rows 

If BA is not valid, another valid BA 

is selected. If no BA is valid, filed is 

cleared. 

Yes No No BA is set automatically in rows. 

Can be selected manually. 

Not valid BA is cleared in all rows. 

Yes Yes Default BA is set to rows if it's valid 

by posting date and by the items. 

Not valid BA is cleared in all rows. 

Valid default BA is selected. 

 

B. When Block multiple BA on same document is selected: 

 When adding new rows or changing rows in non-based documents, BA in row is copied from BA on 

document's header and it is disabled. Item which doesn’t match BA on header cannot be selected. 

 In target documents, header BA is inherited from base document's header BA with no validations 

(date/status). 

 When changing posting date in target documents, if all rows are based, no change in BA (header and rows). If 

some of the rows are not based and BA is not valid, system message is displayed to confirm whether to clear 

the BA or not. 

 When adding documents BA in header has to match BA in all rows and must be valid, except on based rows 

then it can be not valid. 

Additional rules: 
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Allow 

multiple BA 

on same 

period 

Default 

BA is 

set 

Header BA in non-based document 

when selecting business partner 
Changing posting date 

Yes Yes Default BA is selected 

automatically if it is valid by 

posting date. 

If BA is not valid, BA's header and 

rows are cleared. If default BA is 

valid for the new date, it is selected 

in header and rows. 

No N/A Valid BA by posting date is 

selected if BA method is Monetary 

or if only one BA of Items method 

exists. If not field stays empty and 

can be selected manually.  

If BA is not valid, BA's header and 

rows are cleared. If there is a valid 

BA for the new date, it is selected 

in header and rows. 

Yes No Field stays empty and can be 

updated manually. 

If BA is not valid, BA's header and 

rows are cleared. 
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Database Tables Reference 

For information about the tables used in Blanket Agreements, see the Database Tables Reference.chm file. 

You can download it from the SAP Community Network. 

To download the Database Tables Reference .chm file, proceed as follows: 

1. Go to https://www.sdn.sap.com/irj/sdn/businessone → SDN Community → SAP Business One. 

2. Under BUSINESS ONE KNOWLEDGE CENTER, click the link of the SAP Business One release version you 

want. 

3. Click the SDK Help Center link.  

4. In the File Download window, do one of the following: 

o To open the .zip file, choose the Open button and extract the REFDB.chm file to your computer. 

o To save the .zip file to your computer, choose the Save button. You can open the .zip file and extract the 

REFDB.chm file later. 

 

https://www.sdn.sap.com/irj/sdn/businessone
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