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How to Customize Lists 

Introduction 
SAP Business One displays lists of records in List of... windows. Some common examples are the List 
of Business Partners window and the List of Items window.  

Users can perform their jobs more efficiently if the List of… windows are customized according to the 
way they work. For example, when users see only the fields that they actually use, and can sort and 
display these fields based on their needs, they can quickly find the information they are looking for.  

Superusers, and users with full authorizations, can customize List of... windows. These changes then 
take effect for all users who work with that company (that is, all users who are logged onto that 
database). For more information about authorizations, see the document How to Define Authorizations 
in Releases 2007 A and 2007 B in the documentation area of SAP Business One Customer Portal 
(http://service.sap.com/smb/sbocustomer/documentation).  

About This Guide 
This guide is divided into two parts: general information about lists in SAP Business One and business 
examples.  

The general information is a review for all users. It explains how to work with lists in SAP 
Business One.  

The business examples are for superusers and for users with full authorizations in SAP Business One; 
they show the List of... windows that are most often customized. The SAP Business One List of… 
windows and the data shown in them may be different in your application. However, after reading the 
examples, you will be able to apply the concepts explained in this document to suit specific business 
needs. 

General Information About Lists in SAP Business One 
This section is intended for users who are new to SAP Business One and those who need a quick 
review of lists. It discusses the following topics: 

• The list icons used in SAP Business One 

• What the list icons mean and when they are displayed 

• How to use a typical List of… window 

List Icons 
By default, the Choose From List Fields  indicator, the List Selection  icon, the Choose from List  
icon or Arrow down  icon displays if a field or column is, or can be, populated with a value from a list. 
The Delivery window below shows examples of the three icon types. Clicking any of these displays the 
corresponding List of… window. 
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The following table explains how to use the SAP Business One list icons. 

Icon Description To hide/show the icon 

List Selection  The field can be populated from 
a list, and you can currently 
select a value from the list. 
Clicking the icon opens a 
separate window. 

From the menu bar, choose 
View → Pickers Display → List 
Selection. This setting is 
user-specific and does not 
affect other database users. 

You can display List of... 
windows by pressing the TAB 
key in the selected field. 

Choose From List Fields  The field can be populated from 
a list, but you cannot currently 
select a value from the list as 
the field is not currently active. 

From the menu bar, choose 
View → Indicator Display → 
Choose From List Fields. This 
setting is user-specific and does 
not affect other database users. 

You can display List of... 
windows by pressing the TAB 
key in the selected field. 

Choose from List  The field can be populated from 
a list, and you can currently 
select a value from the list. 
Clicking the icon opens a 
separate window. It is also 
possible to select a value for 
this field from a dropdown list. 

Always shown 

Arrow down  You can choose a value from a 
dropdown list without opening a 
separate window. 

Always shown 
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Using a List of… Window 
The options explained below are common to all List of… windows. The List of Business Partners 
window serves as an example.  

 

 

Use the options in the List of Business Partners window as follows: 

To… Do This… 

Quickly locate a business partner from the list 
using the Find field 

Specify a letter or number in the Find field. The 
application automatically displays values from the 
list that begin with the character(s) you specified.  

In the window above, the BP Code field is the 
active sort column (indicated by the black 
triangle). Assume the BP code you are seeking is 
C58373. You might specify C58 in the Find field. 
The application would display all records 
beginning with C58, and C58373 would appear 
near the top of the list.  

Depending on the information in the active sort 
column, the values are sorted alphabetically, 
numerically, or both. The window above is an 
example of both alphabetical and numerical 
sorting. A BP Code that begins with C appears 
before those that begin with D, and C00001 
appears before C00002, and so on. 

Change the Find field sort criterion and sort 
direction 

Double-click a column heading. A black triangle 
appears indicating the column is the active sort 
column for the values you specify in the Find field.

Double-click the active column heading to make 
the sort ascending or descending. The black 
arrow changes to indicate the direction of the sort.
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To… Do This… 

Select a value from the list Highlight the appropriate value in the list and 
choose the Choose button or double-click on the 
value.  

The List of… window closes automatically and the 
selected value appears in the field from which you 
displayed the list. 

Exit without choosing a value from a list Choose the Cancel button. The List of… window 
closes automatically. 

Create a new value from a List of… window Choose the New button. 

Assume you are in the List of Business Partners 
window. Choosing the New button displays the 
Business Partner Master Data window. Use it to 
create a new business partner record. When you 
save the new business partner’s information, the 
new business partner appears in the field from 
which you displayed the list. In addition, the next 
time you display the List of Business Partners 
window, the new business partner appears in the 
list. 

Business Examples 
The following business examples show superusers and users with full authorizations how to customize 
common List of… windows in SAP Business One. You can apply these sample procedures when 
customizing other lists you use regularly. 

 CAUTION 
Changes you make to List of… windows affect all users who work with this company. 

All the business examples use the List of – Settings window to customize the active List of... window. 
The checkboxes, buttons, and sort field in the List of – Settings window are standard, but each window 
looks different, depending on how it has been used to customize the active List of... window.  

Each business example shows you how to use different options in the List of – Settings window. Read 
all the examples to ensure you know how to use all the options. 

Replacing Fields in a List of… Window  
In this scenario, the users regularly access the List of Business Partners window and need to see the 
contact person at the business partner, but not the balance on the business partner’s account. By 
default, the window shows the fields BP Code, BP Name, and BP Balance. 

Procedure 
... 

1. From the SAP Business One Main Menu, choose Sales A/R → Delivery. 

The Delivery window appears. 

2. In the Customer field on this Delivery window, click the List Selection  icon. 

The List of Business Partners window appears. 
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3. Choose Tools → Form Settings in the menu bar or click  Form Settings in the toolbar. 

The List of – Settings window appears. The window shows the settings for the fields that 
currently appear in the List of Business Partners window. 

 
 

 Note 
These are the default fields for the List of Business Partners window. You can restore 
these defaults (if you remove or change them) by choosing the Restore Default button. 

4. To display the business partner’s contact person instead of the account balance, click Account 
Balance and choose Contact Person from the dropdown list. 
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Contact Person replaces Account Balance. 

5. To see a column heading other than Contact Person in the List of Business Partners window, 
specify a new name in the Displayed Name field. 

When you replace or add a new field in the Field Name column, you have the option to specify a 
different name for the field in the Displayed Name column. Use a name that is meaningful to 
your company’s users and consistent with the other fields in the window. For this example, enter 
BP Contact Name. 

 
 

If the text in the Field Name column is what you want the users to see in the List of Business 
Partners window, skip this step. 

6. Choose the Update button, and then choose the OK button. 
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The List of – Settings window closes and you are returned to the List of Business Partners 
window. 

7. To see your updates, close this window and reopen it. 

You now see the business partner contact person’s name. 

 
 

... 

Result 

The List of Business Partners window displays the business partner contact information for all users 
who are logged on to this company, regardless of how the window is accessed in SAP Business One. 

Adding and Grouping Fields in a List of… Window  
In this scenario, to display item details, the users access the List of Items window, which displays 
thousands of item records. To reduce search time, users would prefer to search the List of Items 
window by item group and initially see only this field, with the option to drill down to display the item 
number and number of items in stock. To help identify items, users also want to see an item property, 
but, again, only by drilling down to see it. By default, the List of Items window shows the fields Item 
No., Item Description, and In Stock (the number of items in stock). 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Delivery. 

The Delivery window appears. 

2. In the Customer field, choose a business partner. 

3. Click the first row in the Item No. column and choose the List Selection  icon. 
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The List of Items window appears. 

 
 

4. To display the List of – Settings window, choose Tools → Form Settings from the menu bar or 

click  Form Settings in the toolbar. 

The List of – Settings window appears. 
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5. In the Field Name column, click the blank field below In Stock and choose Item Group. 

 
 

6. To see a column heading other than Item Group in the List of Items window, specify a new 
name in the Displayed Name field. 

 
 

7. To ensure that Item Group (or the Displayed Name, if you specified one) is the only field initially 
visible in the List of Items window, select the Group and Visible checkboxes in the Item Group 
row. This causes all the other fields in the List of Items window to be grouped under Item Group. 
You can expand the group to see the other fields in the window. 

8. In the Field Name column, click the blank field below Item Group and choose Property 1. 
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9. For each field in the List of – Settings window, use one or more of the following options, as 
required: 

 Select the Group checkbox for one field as shown above, or select it for more than one 
field to create a tree structure. The hierarchy for multiple grouped fields is the order in 
which they appear in the List of – Settings window. For example, if you selected the 
Group checkbox for the first three fields in the window above, Item No. would be the top 
node on the List of Items window, Item Description the second, and so on. 

 If you select the Group checkbox for a field, you also can select the Visible checkbox to 
display the Field Name (or Displayed Name, if one has been specified) as a column 
heading in the List of… window. If you deselect the Visible checkbox, the Field Name (or 
Displayed Name) no longer displays in the List of… window; however the data for that 
field still displays. 

 Select the Display Descr. checkbox to display the full field value description rather than 
the internal value for fields that have an internal value. For example, if you select the 
Display Descr. checkbox for the Property 1 field, the values Yes or No display instead of 
Y or N. If you select this checkbox for the BP Type field, Customer or Vendor or Lead 
displays instead of C or S or L. 

 Note 
The fields that have internal values depend on the structure of your database, which may 
have been altered after SAP Business One was installed. Check with your database 
administrator if you have questions about which fields have internal values. 

 Set the sort order of the List of Items window. In the screenshot for this example, the 
item groups are sorted alphabetically, in ascending order (A before B and so on). 

10. Choose the Update button, and then choose the OK button. The List of – Settings window 
closes and the List of Items window appears. 

11. Work with the list as follows: 

a. To see your updates, close the List of Items window and reopen it. 

b. To see the grouped field information, click the + (plus) sign in front of an item group. 
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c. To simultaneously open or close all the item information, choose the Expand All or 
Collapse All button, respectively. 

 
 

Result 

When opened, the List of Items window shows only the item group, but lets users display additional 
item details, including Property, when necessary. 
... 

Inserting Fields in a List of… Window 
The Copy From function lets you create documents, such as sales orders, based on an existing 
document. If users access the Copy From function regularly, you can customize the list of source 
documents, enabling all users to quickly identify a document and copy its information to another 
document.  

In this scenario, there are several open sales orders for a business partner, with several items in each 
order that are on back-order. When items on back-order arrive at your warehouse, users regularly 
copy the item information from the business partner’s existing sales orders to create delivery 
documents. You want to make sure that sales orders that are nearing their cancellation date are taken 
as the basis for deliveries first, before more recent sales orders. Therefore, you need to insert the 
Cancellation Date field into a quickly identifiable position on the List of Sales Orders window. 

Procedure 

1. From the SAP Business One Main Menu, choose Sales A/R → Delivery. 

The Delivery window appears. 

2. In the Customer field, specify a business partner with existing sales orders. 
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3. Choose the Copy From button and choose Sales Orders. 

The List of Sales Orders window appears: 

 
 

4. Choose Tools → Form Settings from the menu bar or click  Form Settings in the toolbar. 

The List of – Settings window appears. 
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5. To add a blank row for the cancellation date field, right-click the Customer/Vendor Name field 
and choose Add Row. The new row is inserted above the field you selected. 

In this business example, users typically search for sales orders by their numbers and dates. 
Users must now also check the cancellation date. Therefore, row 3 is a suitable place for the 
new field. 

6. From the dropdown list of the new row, in the Field Name column, select Cancellation Date. 

7. To see a column heading other than Cancellation Date in the List of Sales Orders window, 
specify a new name, such as Cancellation, in the Displayed Name field. 
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8. Choose the Update button, and then choose the OK button. The List of – Settings window 
closes and the List of Sales Orders window appears. 

9. To see your updates, close the List of Sales Orders window and reopen it. 

10. To continue with the Copy From process, highlight a sales order nearing its cancellation date 
and choose the Choose button. 

 
 

11. Complete the copying process in the draw document wizard. For more information about this 
wizard, see the online help for SAP Business One. 

Result 

The List of Sales Orders window now displays the sales order cancellation date. Users can use this 
information to decide whether or not to copy information from a sales order to another sales 
document, such as a delivery. 
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Authorizations 
For information about the authorizations required for customizing lists, see the online help as well as 
the document How to Define Authorizations, which you can download from the documentation area of 
SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation. 
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Copyrights, Trademarks, and Disclaimers 
© Copyright 2009 SAP AG. All rights reserved. 

 

The current version of the copyrights, trademarks, and disclaimers at 
http://service.sap.com/smb/sbocustomer/documentation is valid for this document. 
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